当前位置:博客首页>>wordpress >> 阅读正文

解决Lnmp环境下WP升级安装插件时的ftp权限提示

作者: 郑晓 分类: wordpress 发布于: 2012-10-07 23:32 浏览(5,503) 评论(1)


近日搞了台VPS练练手,安装好基本的lnmp环境后就把wordpress博客放上去了。后来发现在博客后台升级插件和在线安装主题时wordpress竟提示:“要执行请求的操作,WordPress 需要访问您网页服务器的权限。 请输入您的 FTP 登录凭据以继续”,同时还显示有一个表单让输入ftp账号密码。

这种问题很明显是由于当前网站目录的权限没有配置好导致的,所以解决方法就是修改文件夹权限即可。

我的解决办法如下:

1.使用putty登录vps。

2.直接执行 chown −R www /home/wwwroot  即可。

因为我的博客是放在的根目录中,所以直接使用/wwwroot。使用chown命令来把wwwroot目录的所有权限设置为www,具体为什么设置为www我也不太了解。

 

↓↓微信扫码请我吃份正宗的烤面筋,可带劲啦↓↓
       

本文采用知识共享署名-非商业性使用 3.0 中国大陆许可协议进行许可,转载时请注明出处及相应链接。

本文永久链接: https://www.zh30.com/jie-jue-lnmp-huan-jing-wordpress.html

解决Lnmp环境下WP升级安装插件时的ftp权限提示:目前有1 条留言

用户评论头像 安卓博客发表于 2012年11月08日 13:06[回复]

来个沙发